2012 m. gegužė 25 d., penktadienis

Teo: Gala Televizija ir Zebra Internetas savo maršrutizatoriuje – TP-Link WR1043ND su OpenWRT pavizdys

Už Teo siuloma Comtrend – gerbiamas tiekėjas norėjo 300 lietuvišku. Kas dar nepatiko - kad Teo kaip ir be musu žinios sukuria Wi-fi prieiga visiems kas turi Web koda, kas mane ne labai žavi. Gerai kai optika, o jeigu aDSL - ir kaimynelis per Wi-fi pumpuoja torrentus CentOS instala ir pasiima mano linijos trafika - Na kagi pradedam ieškoti alternatyvos.

Iš pradžiu panagrinekime Comtrend wap 5813n konfiguracija arba  ADBB P.RG EA4201N ar Pirelli DRG125G  kad žinotumeme kokio routerio mums reikia. Dar Comtrendas dirba gerai, kuo negalima pasakyti apie kitus siulomus routerius, kaip ADBB – kraunasi apie 2 minutes!!!

 

Topologija routeryje yra pavaizduota apačioje:

 


VLAN1 – yra zebros internetas
VLAN5 - MGMT – Managemento arvba valdymo (savo routeri as ne duosiu valdyti, tai vlan5 net ne jungsim)
VLAN6 – IPTV STB

Taigi mums reikia routerio kuris palaiko VLAN kurima, pigiausias variantas tai maršrutizatoriai kuriems galimas custom open source firmware DD-WRT arba OpenWRT įpusti..
Bukite atidus kai renkate maršrutizatoriu – mano routeryje OpenWRT – palaike vlanu konfiguravimą  o su DD-WRT tik galėjau uztagginti.

http://wiki.openwrt.org/toh/start pasitikrinam ar mūsų būsimas maršrutizatorius palaikys VLAN Config`a.

Buvo nupirktas TP-Link WR1043ND  - 400 Mhz CPU Speed, 32Mb RAM, 4 Mb Flash ir VLNA config Yes - tokio routerio kaina svyruoja apie 160 lt. Dvigubai pigiau ir trigubai gerėsnis uz Comtrend‘a.


Comtrend 5813n - 400 Mhz CPU Speed, 64 Mb RAM, 4 Mb Flash ir VLAN config - yes - taip jo  RAM dvigubai - bet atrodo jis ne kaip už 300 lt ir ne kaip už 160 :)


ADBB P.RG EA4201N - nerasta, kas turite permeskite į komentus - atnajinsiu info


ir aDSL siulomi maršrutizatoriai 


 PIRELLI DRG A125G - 240 Mhz, 16 RAM, Flash 4 MB ir VLAN config Yes.


ADBB PDG A4001N - nerasta, kas turite permeskite į komentus - atnajinsiu info



Let’s start. Step by Step.

http://downloads.openwrt.org/backfire/10.03.1/ar71xx/ persiunčiame versija savo routeriui.

openwrt-ar71xx-tl-wr1043nd-v1-squashfs-factory.bin – jeigu is originalios TP-Link firmware per system tools pakeičiam į OpenWRT

openwrt-ar71xx-tl-wr1043nd-v1-squashfs-sysupgrade.bin – pakeičiam į paskutinę versiją, jeigu jau routeryje yra OpenWRT.
 
Po sekmingo maršrutizatoriaus firmware pakeitimo, pasijungiam per WEB arba per Terminala prie Ip adreso pagal nutilejima jis yra 192.168.1.1
1.       Uzdedam slaptazodi.
2.       Isijungia SSH – todel jau reikia jungtis per tool`sus kuris palaiko SSH – Putty.exe. 

 

Užeinameįi tinklo configuravima per console kuri randasi

/etc/config/network


spaudžiam 'i' arba 'a'

Ir surasome toki konfiga –
==============================================================
config 'interface' 'loopback'
       option 'ifname'   'lo'
       option 'proto'    'static'
       option 'ipaddr'   '127.0.0.1'
       option 'netmask'  '255.0.0.0'

config 'interface' 'lan'
        option 'ifname'   'eth0.1'
        option 'type'     'bridge'
        option 'proto'    'static'
        option 'ipaddr'   '192.168.1.1'
        option 'netmask'  '255.255.255.0'
        option dns '208.67.222.222 212.59.1.1 208.67.220.220'

config 'interface' 'wan'
        option 'ifname' 'eth0.2'
        option 'proto' 'dhcp'

config interface 'vlan6'
        option ifname 'eth0.6'
        option proto 'none'
        option defaultroute '0'
        option peerdns '0'

config 'switch'
        option 'name' 'rtl8366rb'
        option 'reset' '1'
        option 'enable_vlan' '1'

config 'switch_vlan'
        option device 'rtl8366rb'
        option 'vlan' '6'
        option ports '0t 4 5t'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '1'
        option 'ports' '1 2 3 5t'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '2'
        option 'ports' '0 5t'

===============================================================
Po pakeitimu spaudžiam:


1. esc    <- išeiti iš amendments 
2. esc
3.   :       <- leidžia rašyti komandas
4.  wq!   <- wruite and quite
5. Enter <- patvirtinam


dd - trinti eilute 


vi redaktoriuas komandos -http://ss64.com/vi.html angliškai arba rusiškai http://lib.ru/unixhelp/vi.txt

Konfigas 100% veikia 3 dienas uptime, bandymams atlikti buvo siunciame linuxo distributivai, naudojamasi wi-fi ir ziurima HD kokybes Natioanl Geographic – jokiu lagu, jeigu turite lagus, perkraukite Motorolla IPTV Box`a.
Ka mes jame pridejome – mes pridejome dar viena interfeica vlan6 – ir priskirem jam 4 porta

config 'switch_vlan'
        option device 'rtl8366rb'
        option 'vlan' '6'
        option ports '0t 4 5t'

Ir aprasome kad internet vlan1 tinklas eitu tik i 1,2,3 portus –

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '1'
        option 'ports' '1 2 3 5t'

Mes neitraukem VLAN5 – Teo managementas nereikalingas.

Mano konfigas pries routerio network nustatymu pakeitima atrode sitaip

config 'interface' 'loopback'
       option 'ifname'   'lo'
       option 'proto'    'static'
       option 'ipaddr'   '127.0.0.1'
       option 'netmask'  '255.0.0.0'

config 'interface' 'lan'
        option 'ifname'   'eth0.1'
        option 'type'     'bridge'
        option 'proto'    'static'
        option 'ipaddr'   '192.168.1.1'
        option 'netmask'  '255.255.255.0'

config 'interface' 'wan'
        option 'ifname' 'eth0.2'
        option 'proto' 'dhcp'

config 'switch'
        option 'name' 'rtl8366rb'
        option 'reset' '1'
        option 'enable_vlan' '1'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '1'
        option 'ports' '1 2 3 4 5t'

config 'switch_vlan'
        option 'device' 'rtl8366rb'
        option 'vlan' '2'
        option 'ports' '0 5t'

Kaip matote viskas labai nesunku- sekmes konfiguruojant.

Enjoy!


p.s. dar yra toks konfigas
http://lag.lt/wr1043nd-gala-tv/

sukeisti vlan1 ir vlan2;  ir eth01 ir eth02 priskirti skirtingiems interfeisams

78 komentarai:

  1. dekui uz instrukcija,
    pasidariau kad veiktu ant portu bet per wifi niekaip,
    isejo pasidaryt kad rodytu bet rodo su ziauru strigimu 120kb/s max tada buna vietoj 500kb/s kur turetu,
    gal turi patarimu del wifi?

    AtsakytiPanaikinti
  2. padidejo speed 150Mbps bet meginant be Galos traukia iki 30Mbps o su Comtrend siekdavo ir 70Mbps per wifi

    su gala per wifi tas pats vos juda ir puslapius tada sunkiai varto arba skype kartais atsijungia ir atrodo kazkas blokuoja :?

    dar radau kita config:
    http://lag.lt/wr1043nd-gala-tv/

    parasyta kad veikia per wifi reiks meginti :)

    AtsakytiPanaikinti
    Atsakymai
    1. del greicio per wifi jau tvarkoje,

      problemos tik per wifi ziuret :?

      Panaikinti
    2. Geras, aciu uz linka, gaila ji ne radau anksciau, sutaupyciau kruva laiko.

      o kaip sitas ar padejo:

      Jei norisi per WiFi žiūrėt GALA – tai dar reik įrašyti į /etc/rc.local:

      ifconfig eth0.6 10.10.99.1 up
      udpxy -p 4022 -m 10.10.99.1 -B 4Kb -c 10
      exit 0

      Panaikinti
    3. pridejus tas eilutes nieko nepasikeite, nors ir visa config'a pakeitus lygiai tas pats :(

      gal kad ten meginta su RC5/RC6 versija o pas mane jau ne RC :?

      kazin eitu kaipnors per udpxy :?

      Panaikinti
    4. Deje Evaldai daugiau nieko ne patarsiu, gal veliau kaip turesiu laiko paeksperementuoti su wi-fi. Nes kolkas wi-fi nauduoju tik androidui.

      Panaikinti
    5. Evaldai, iš pradžių į openwrt reikia suinstaliuoti udpxy:
      opkg update; opkg install udpxy

      pridėti į /etc/config/firewall:

      config rule
      option src wan
      option proto igmp
      option target ACCEPT

      config rule
      option src wan
      option proto udp
      option dest_ip 224.0.0.0/4
      option target ACCEPT


      tada perkrauti firewall:
      fw restart

      tada pridėti į /etc/rc.local prieš pabaigą:
      ifconfig eth0.6 10.10.99.1 up
      udpxy -p 4022 -m 10.10.99.1 -B 4Kb -c 10

      exit 0


      ir įvykdyti:
      /etc/rc.local

      Viskas, veikia su vlc žiūrint:
      http://10.10.99.1:4022/udp/239.2.3.12:1234

      Panaikinti
    6. Viska padariau kaip surasyta bet jokios reakcijos :(

      Panaikinti
    7. Veikia su kitu configu :O
      http://lag.lt/wr1043nd-gala-tv/

      Panaikinti
    8. xm, skirtumas yra tik VLAN


      config 'switch_vlan'
      option 'device' 'rtl8366rb'
      option 'vlan' '1'
      option 'ports' '1 2 3 5t'

      config 'switch_vlan'
      option 'device' 'rtl8366rb'
      option 'vlan' '2'
      option 'ports' '0 5t'

      O pas kolega

      config 'switch_vlan'
      option 'device' 'rtl8366rb'
      option 'vlan' '1'
      option 'ports' '0 5t'

      config 'switch_vlan'
      option 'device' 'rtl8366rb'
      option 'vlan' '2'
      option 'ports' '1 2 3 5t'


      bet tada su mano pas tave Evaldai net internetas neturetu veikti :\

      Panaikinti
    9. su tavo man nekrove tiesiog galos bet viskas kitkas veike, su kitu configu veikia viskas puikiai, dar galiu streaminti kad ir HD kanalus draugams :)

      Panaikinti
    10. Video paduodamas per Vlan6 ir konfigas vienodas sitoje vietoje :) nes jeigu nauduotum versija ta pacia kuria ir as- 0tikrai veiktu, tai manau gal su eth02,eth01 ir vlan2 ir vlan1 pripainiota, del openwrt versiju skirtumu.

      Panaikinti
  3. Aciu, del Open Source judejimo ir stengiames. per wi-fi nebandziau tv ziureti, o klausiams butu toks ar uzdeta B+n standartas ir HT mode 40 Mhz?

    reikia prideti butinai sias eilutes wifi-iface - tai jungs tavo n standarta ir wi-fi gales palinti 300 mb - teoriniu :)

    option 'noscan' '1'

    o kur wifi-device

    option 'hwmode' '11ng'
    option 'htmode' 'HT20'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'DSSS_CCK-40'
    restart your device!
    Ir nepamirsk atrasyti - kai rasi sprendima :) idesiu i posta - share your knowledge.

    Po testu mano laptopas nors ir raso kad N palaiko - tik irgi isspaude 350 kbps siusdamas ubuntu, o staciaonarus su wi-fi adapteriu - 3,5 mbps.

    Pilnas configas atrodytu taip:

    root@OpenWrt:~# vi /etc/config/wireless

    config 'wifi-device' 'radio0'
    option 'type' 'mac80211'
    option 'channel' '11'
    option 'macaddr' 'b0:48:7a:f6:6f:1e'
    option 'hwmode' '11ng'
    option 'htmode' 'HT20'
    list 'ht_capab' 'SHORT-GI-40'
    list 'ht_capab' 'DSSS_CCK-40'
    option 'txpower' '27'
    option 'country' 'US'

    config 'wifi-iface'
    option 'device' 'radio0'
    option 'noscan' '1'
    option 'network' 'lan'
    option 'mode' 'ap'
    option 'key' 'tAv0 SlaptaZ0dis'
    option 'ssid' 'wifi'
    option 'encryption' 'psk2'

    AtsakytiPanaikinti
    Atsakymai
    1. Pavlik - neteisinga si opcija - nedirbs 2 kanalais

      option 'htmode' 'HT20'

      keiciam i
      option 'htmode' 'HT40+'
      arba
      option 'htmode' 'HT40-'

      taip pat keicame kanala i Auto

      option 'channel' 'auto'

      option 'noscan' '1'
      turi buti
      config 'wifi-device' 'radio0' dalyje



      Panaikinti
  4. Gal gali paaiskint kas turi buti padaryta? Is tavo konfigo nieko nesuprantu, o man reikia pasidaryti panasu reikala, su debian routeriu. Tik skirtumas pas mane tas, kad nenoriu terst lan nereikalingais paketais, tai visa gala trafika reikia siusti per atskira tinklo plokste.

    AtsakytiPanaikinti
  5. Sveikas Laurynai,
    Gala tv eina per 6 vlana:

    1. Reikia sukurti vlan6
    2. Priskirti vlan6 - virtulu interfeica e.g. eth0.6

    3. Permesti eth0.6 nuo wan porto i vidine tinklo korta.

    Bridge eth0.6 from WAN port to router 4 port.
    Kad galima butu per 4 routerio porta ziureti telika per STB.

    Sekmes

    AtsakytiPanaikinti
  6. Laba,
    Gal kas yra Gala srautą persikėlę ant LAN naudojant IGMP Proxy?

    Man kažkas pavyko, bet pasijungiant per VLC kanalą, iškart nukrenta beveik visas Wlan greitis.

    Dabartinė konfigūracija

    igmpproxy.conf:
    quickleave

    phyint eth0.6 upstream ratelimit 0 threshold 1
    altnet 150.158.231.0/24
    altnet 10.0.0.0/8
    altnet 192.168.0.0/24

    phyint eth0.2 downstream ratelimit 0 threshold 1

    phyint lo disabled
    phyint wlan0 disabled
    phyint eth0.1 disabled


    firewall.user:
    iptables -I FORWARD -s 150.158.231.0/24 -d 224.0.0.0/4 -j ACCEPT
    iptables -I FORWARD -s 10.0.0.0/8 -d 224.0.0.0/4 -j ACCEPT
    iptables -I FORWARD -s 192.168.0.0/24 -d 224.0.0.0/4 -j ACCEPT

    iptables -I INPUT -d 224.0.0.0/4 -j ACCEPT
    iptables -I FORWARD -d 224.0.0.0/4 -j ACCEPT


    firewall:
    config 'rule'
    option 'src' 'wan'
    option 'proto' 'igmp'
    option 'target' 'ACCEPT'
    option '_name' 'igmp'

    config 'rule'
    option 'src' 'wan'
    option 'proto' 'udp'
    option 'dest' 'lan'
    option 'dest_ip' '224.0.0.0/4'
    option 'target' 'ACCEPT'
    option '_name' 'igmp_udp'

    AtsakytiPanaikinti
  7. Jei vdrug kam prireiks ant jo porta persmesti is isores i vidini koki kompa tai darom taip:
    vi /etc/config/firewall
    config 'redirect'
    option 'src' 'wan'
    option '_name' 'web'
    option 'proto' 'tcp'
    option 'src_dport' '80'
    option 'dest_ip' '192.168.0.YYY'
    option 'dest_port' '80'

    o kad isvengti “Rejected request from RFC1918 IP to public server address”:
    vi /etc/firewall.user
    iptables -t nat -A prerouting_rule -d XX.XX.XX.XX -p tcp --dport 80 \
    -j DNAT --to 192.168.0.YY
    iptables -A forwarding_rule -p tcp --dport 80 -d 192.168.0.YY -j ACCEPT
    iptables -t nat -A postrouting_rule -s 192.168.0.0/24 -p tcp --dport 80 \
    -d 192.168.0.YY -j MASQUERADE

    Kur 192.168.0.YYY jusu kompo ipiske, o xxx jusu ip kur provaideris suteike

    AtsakytiPanaikinti
  8. Sveiki,
    Susidūriau su problema: testuoju konfigą ir per DHCP iš WAN negaunu IP adreso. Bėda tame, kad paketai iš WR1043ND išeina per VLAN2, o grįžta per VLAN6. Kol kas žaidžiu ne TEO tinkle, bet ant porto ateinantys netaginti paketai kažkodėl užtaginami VLAN6.
    Ar kam yra tokios bėdos?

    AtsakytiPanaikinti
  9. Super dėkui už gidą, konfigas veikia tik iš lag.lt, kuris aprašytas čia - neveikia

    AtsakytiPanaikinti
  10. Klausimas gerbiamiems ekspertams. Ar gali veiki interaktyvioji su motorola vip 1003 pajungus be routerio? Pajungus prie kompo internetas yra, per vlc lnk eina o pajungus tiesiai i tv tv priedeli ... ilgai blygcioja pirmas geltonas po to uzsidega zalias, po to greitai uzsidega antas zalias, po to greitai 3 raudonas ir motorola restartuojasi, taip vel viskas is pradziu :(

    AtsakytiPanaikinti
    Atsakymai
    1. Labas, nesuprantu kaip tau gali per PC paleisti kanalą tiesiogiai nuo keitiklio.
      Per priedėlį nepagaus tiesiogiai be routerio.

      Panaikinti
  11. pasiemiau wr740 piguji routeriuka, su mintim, kad išeis padaryti tą pati… dėja… kažkaip sumaišyti portai, neina atskirti man jų… gal kas padėti gali?

    AtsakytiPanaikinti
  12. Comrade - pacioje apacioej straipsnio yra du variantai kai buna
    vineas mano o kitas taip apt buvo surastas kolegomis tik kai portai truputi kitaip sukonfiginti
    http://lag.lt/wr1043nd-gala-tv/

    ir visas skirtumas konfigu, prasome perskaityt viska atidziai. Turesiu laiko perrrasysiu viska graziai ir vartotojo kalba.
    Sekmes

    AtsakytiPanaikinti
  13. tikrai reikėtų "žmonių kalbos" nes dabar sunku suprasti, pvz ką reiškia
    option 'ports' '0 5t'
    ir kuo skiriasi nuo
    option 'ports' '1 2 3 4 5t'

    ir ar įrašas
    option 'name' 'rtl8366rb'
    yra universalus ir tinka visiems modeliams, ar kiekvienas tplinkas turi savo pavadinimą..? Ir ar apskritai ta eilute reikalinga?

    AtsakytiPanaikinti
  14. laba,
    5t - reiskia 5 portas tagget, o be raides untagged.
    rtl8366rb tai realtek RTL8366RB chipas tinklo plokstes routeryje.

    AtsakytiPanaikinti
  15. užbrikinau routeri :)
    susivirinau pagal pavizdį ( http://wiki.openwrt.org/toh/tp-link/tl-wr740n#uart.on.v4.23 ) ir laukiu com kontrolerio iš ebay :)
    kai susitvarkysiu reiks toliau aiškintis kaip ten veikia wr740 portai, nes ant jo padaryti tą patį tikrai turėtų išeit...manau..

    AtsakytiPanaikinti
  16. are you shure? Bandej per wan porta per terminala jungtis pries tai ji nuresetinus ?
    http://www.xinotes.org/notes/note/1443/

    AtsakytiPanaikinti
    Atsakymai
    1. Labas Pavlik. Ar galima gauti daugiau informacijos kaip sukonfiginti Comtrend wap 5813n (ziureti TV per Wifi), kadangi jis buvo "iteiktas" teo. I ji ipusti OpenWRT neimanoma.

      Dekoju is anksto.

      Panaikinti
    2. Sveiki kaip padaryti kad TP-Link 1043 per 4 jungti eitu ir Gala ir internetas, dabar per 4 jungti eina tik Gala, ir niekaip negaliu paleisti per WiFi , dariau viska kaip surasyta

      Panaikinti
    3. Tu tiesiog nepadarei ką rašė Sielturys2012 m. birželis 15 d. 09:28, viskas veikia kai taip padarai, udpxy iš udp perdaro į http taip matytum gala per visus portus + wifi.

      Panaikinti
  17. Sveiki dar karta gal kas nors galetu man numesti savo ruterio issaugotus nustatymus ( chadulia@gmail.com )OpenWrt arba DD-WRT kad rodytu Gala ir butu inernetas per 4 lizda nes niekaip nesusitvarkau ,gaunasi tik kad rodo Gala o interneto nera ,viska dariau kaip auksciau aprasyta ruteris TP-Link 1043 ,Aciu.ir visus su artejanciais naujais metais !!!

    AtsakytiPanaikinti
    Atsakymai
    1. internetas ir gala per udpxy yra 1,2,3 portuose, o TIK RAW gala tiesioginiam žiūrėjimui per UDP yra 4 porte.

      Panaikinti
  18. Pavlik, visiškai "shure". Nes ijungus routeri visos lemputės užsidega ir užgesta, užsidega ir užgesta, įspūdis lyg routeris persikrovinėtų.
    Beje, gal kol laukiu com kontrolerio atbrikinimui galėtum pasidalinti žiniomis, kaip konfigūruoti portus galai su openwrt?
    Priminsiu kad routeris pigusis TL-wr740, ir kolkas neatskyriau portų numeracijos bei ką ten taginti, ko ne... Taip pat man neaiški ta vieta su
    option 'name' 'rtl8366rb'
    chipas tas pats ar ne...?
    Užsiprenumeravau komentarus e-paštu. atsakysiu operatyviai :)

    AtsakytiPanaikinti
  19. Sveikas, Pavlik. Man iškilo problemų su adbb ea4202n routeriu, kai įsivedžiau šviesolaidį. Kaip teo žmonės iš 1817 sako, kad internetas yra, visa kita ne jų problemos, tai ir bandau pats aiškintis, nors esu visiškai žalias šiuose reikaluose.
    Problema tame, kad neišeina prisijungt prie online žaidimų. Kai perkraunu routerį per naršyklę, prisijungti galiu, tačiau nebegaudo wifi kitas laptopas, tada reikia perkraudinėt vėl per laidus. portus atrodo irgi atsidariau, mėginau dar per telnet dėl visa ko, tačiau nelabai moku. Ar yra tekę susidurt su tokiom problemom, gal žinai jos sprendimo būdą?
    Firmware Version: PRGEA4202N_TEO_2.1.1.0010 - main
    Platform Version: 2.1.0.0019
    Hardware Version: BCM6362

    AtsakytiPanaikinti
    Atsakymai
    1. Gal kam pravers labai geras aprasymas kiek suprantu gautas is TEO rastas kitam forume
      https://www.dropbox.com/s/9qxvnixsyahnjpo/Paslaugu_diegimas_ir_sutrikimu_diagnozavimas_-_ADBB_EA4201N-G_v2.pdf

      Panaikinti
    2. na, deja arba neradau, kaip tai sutvarkyti, arba nėra čia aprašyta. Gal kas naudojasi šiuo routeriu ir žino, kaip sutvarkyti šią problemą?

      Panaikinti
  20. Sveiki, nepavyksta paleisti udpxy ant Netgear WNDR3700 routerio su OpenWRT. Internetas ir IPTV į STB per portus veikia puikiai, tačiau priskyrus VLAN 6 IP ir bandant žiūrėti per LAN su udpxy, nieks nevyksta. Log'e tokia klaida:

    udpxy[20506]: read_buf: read: Resource temporarily unavailable

    Firewall įvesti standartiniai nustatymai:

    config 'rule'
    option 'src' 'wan'
    option 'proto' 'igmp'
    option 'target' 'ACCEPT'
    option '_name' 'igmp'

    config 'rule'
    option 'src' 'wan'
    option 'proto' 'udp'
    option 'dest_ip' '224.0.0.0/4'
    option 'target' 'ACCEPT'
    option '_name' 'igmp_udp'

    Gal kas galėtų pasidalinti veikiančiais config? Kas galėtų būti ne taip?

    AtsakytiPanaikinti
  21. Autorius pašalino šį komentarą.

    AtsakytiPanaikinti
  22. Autorius pašalino šį komentarą.

    AtsakytiPanaikinti
  23. Autorius pašalino šį komentarą.

    AtsakytiPanaikinti
  24. Atsargiai, pasitaikė atvejų, kad tiems kurie viešai pertransliuodavo teo iptv, būdavo tiesiog tyliai atjungiamas iptv udp srautas, aišku kita situacija jei turėdavai užsisakęs gala... bet kas žiūrit dykai, saugokit privatumą :)

    AtsakytiPanaikinti
  25. Sveiki, gal kas yra pasikonfigines sita reikala su adsl2+ routeriuku? Ir gali pasiuliti koki routeri isigyti nes net neisivaizduoju. Nes manasis pirelis tiesiog zudo kai nori ka nors pazaisti pingas visada ~100+

    PS. as turiu uzsisakes gala iptv ir noriu pasileisti su kitu routeriu.

    AtsakytiPanaikinti
  26. Sakykite, prašau,ar pažangiems routeriams užtenka tik įvesti VLAN.6 ir priskirti kurį nors LAN prievadą:

    [img]http://www.paulita.lt/Img/RV220W.jpg[/img]

    ar reikalingi dar kokie nors nustatymai?

    AtsakytiPanaikinti
  27. Sveiki, reikalingas 'Bridge' VLAN6 tarp WAN porto ir bet kurio LAN, i kuri jungsite Set Top Box`a (TV priedeli).

    AtsakytiPanaikinti
  28. Čia http://www.cisco.com/en/US/docs/routers/csbr/rv220w/administration/guide/rv220w_ag_78-19743.pdf nerandu 'Bridge'. Gal kaip kitaip ši galimybė vadinasi?

    AtsakytiPanaikinti
  29. Viskas kas ateina i WAN`a vlan6 mums reikia permesti i LAN 4 porta.
    Meginciau tiesiog isjungti firewalla ant routerio, priskirti 6 vlan 4 portui ir pasijungti set top boxa.

    AtsakytiPanaikinti
  30. Na, išjungti visą firewallą tai gal per daug. O gal žinai, kokį portą užtektų?

    AtsakytiPanaikinti
  31. :) Rimvydai- Firewalla isjungti reikia tik for test purpose, veliaa, kaip paleisite GALA TV- Firewalla atgal butinai ijungsit, uzdarysit visus laisvus - step by step.

    AtsakytiPanaikinti
  32. ZTE F660 turiu routeri,problema tame, kad nesuprantu kodel nebeissiuncia torrentu, atsiusti atsiuncia... kazkaip viskas sumakaluota tam routeri, paineva kazkokia, ka daryti ? gal kas turite toki routeri ir galite screena padaryti kaip turi viskas buti,kad viskas normaliai veiktu?

    AtsakytiPanaikinti
  33. Sveiki, sakykite o kaip yra su Tl-WR1043ND V1.10, nes ant sito hardvaro eina jau kita opwnwrt versija ir sitie konfigai nebeveikia, gal jau kas ka isbande esate? Aciu uz informacija

    AtsakytiPanaikinti
  34. matyt nesenai isivedei zebra internetą, nes kaip supratau daugumai ar net visiems nebeveikia iptv, kas neturi užsakę pačios xala tv

    AtsakytiPanaikinti
  35. :) viska as turiu uzsisakes, su routeriu V1.1 ir panasiai kai kita versija openwrt buvo viskas veike, teisiog kai naujam routeri ivedu nauja konfiga tai pats routeris bludija ir nebepriskiria ip adresu, reikia krauti safe moda ir nuresetinti. tad as galvoju kad tas naujas firmvaras ant V1.10 gal reikalauja kazkokio kitokio konfigo ar kazko tokio

    AtsakytiPanaikinti
  36. Attitude Adjustment 12.09-rc1 - dabar i mano routeri dedasi sita versija, o konfigas cia skelbiamas darytas ant Backfire 10.03.1

    AtsakytiPanaikinti
  37. aš ir turiu du 1043nd tplinko routerius vienas 1.8 kitas 1.10
    ant 1.8 veikė labai ilgą laiką, su senu openwrt backfire versija, bet vieną dieną tiesiog nustojo veikti, ir daugiau nebepavyko padaryt kad veiktų, nes nebegaunu iptv TX (nebeina udp iki manes visiškai) ant tos naujausios openwrt rc versijos nebandžiau išvis.
    Pasitikrint gali, pasijunk kompą ant 4 ruterio porto, dings internetas, bet galėsi pažiūrėt ar rodo tau gala kanalus bandant žiūrėti "udp://@" principu, jei nerodys tada "pizdiec" jei rodys reik konfigą tobulint.
    Pamėgink, man pačiam idomu :)

    AtsakytiPanaikinti
  38. Tai suprantama, kad Telekomas vaistų ieškos nuo to. O kas ieško, tas randa :)

    AtsakytiPanaikinti
    Atsakymai
    1. Žinau ne vieną ir ne du kurie kaip žiūrėjo taip žiūri be jokių problemų

      Panaikinti
  39. Kadangi zebra kofnigo nekeite ( pas mane viska rodo sekmingai ir toliau) tai konfigas teisingas, t.y. veikai su tokai konfiguracija, na ir masiskai visuose perpusti konfiguracija - gana sudetinga ir daug bus skambucio i sservice deska ;] kazka painiojat su vlanas, ir interfasais, manau reiketu atidziau panagrineti ka jus turite kaip pradini konfiga ( kuris kuriam interfeisas) ir ka turite surasity.
    Kaip pavizdys:
    pas mane wan yra ant eth0.2 by default, o lan ant eth0.1, pas kitas versijas openwrt- atvirksciai eth0.1 yra wan o lan yra eth0.2 - manau cia buten jusu atvejis, nes sakot kad po restarto tik safe mode galit paskui prieiti.
    In short:
    bandykit sita surasyti savo routeryje - http://lag.lt/wr1043nd-gala-tv/.
    Arba atsiuskite savo pradini konfiga - kai tik paresetinot openwrt- perziuresim, parasysim koks turetu buti. Na ir siulyciau pradzioej isjungti firewalla, po to ijungsite.

    AtsakytiPanaikinti
  40. konfigas iš routerio su nauju FW (neveikiantis lygtai)

    konfigas iš lag.lt http://i.imgur.com/u1devtq.jpg

    network:
    config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1'
    option 'netmask' '255.0.0.0'

    config 'interface' 'lan'
    option 'ifname' 'eth0.2'
    option 'type' 'bridge'
    option 'proto' 'static'
    option 'ipaddr' '192.168.1.1'
    option 'netmask' '255.255.255.0'

    config 'interface' 'wan'
    option 'ifname' 'eth0.1'
    option 'proto' 'dhcp'

    config 'interface' 'vlan6'
    option 'ifname' 'eth0.6'
    option 'proto' 'none'
    option 'defaultroute' '0'
    option 'peerdns' '0'

    config 'interface' 'vlan5'
    option 'ifname' 'eth0.5'
    option 'proto' 'none'
    option 'defaultroute' '0'
    option 'peerdns' '0'

    config 'switch'
    option 'name' 'rtl8366rb'
    option 'reset' '1'
    option 'enable_vlan' '1'

    config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '6'
    option 'ports' '0t 4 5t'

    config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '5'
    option 'ports' '0t 5t'

    config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '1'
    option 'ports' '0 5t'

    config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '2'
    option 'ports' '1 2 3 5t'

    kas idomiausia, mano manymu seniau rodydavo kažkoki ipv4 ip adresą tiek po vlan6 tiek po vlan5, dabar ten tiesiog tuščia (čia ta vieta kur prie lan parašytas vidinis ip)

    AtsakytiPanaikinti
  41. Sveiki, va pradinis konfigas routerio:

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

    config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

    config switch
    option name 'rtl8366rb'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'rtl8366rb'
    option vlan '1'
    option ports '1 2 3 4 5t'

    config switch_vlan
    option device 'rtl8366rb'
    option vlan '2'
    option ports '0 5t'

    :))))

    AtsakytiPanaikinti
  42. Turi buti vienas prie vieno - perrasykit be klaidu vien ant vieno:

    config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1'
    option 'netmask' '255.0.0.0'

    config 'interface' 'lan'
    option 'ifname' 'eth0.1'
    option 'type' 'bridge'
    option 'proto' 'static'
    option 'ipaddr' '192.168.1.1'
    option 'netmask' '255.255.255.0'

    config 'interface' 'wan'
    option 'ifname' 'eth0.2'
    option 'proto' 'dhcp'

    config 'interface' 'vlan6'
    option 'ifname' 'eth0.6'
    option 'proto' 'none'
    option 'defaultroute' '0'
    option 'peerdns' '0'

    config 'switch'
    option 'name' 'rtl8366rb'
    option 'reset' '1'
    option 'enable_vlan' '1'

    config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '6'
    option 'ports' '0t 3 4 5t'

    config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '1'
    option 'ports' '1 2 3 5t'

    config 'switch_vlan'
    option 'device' 'rtl8366rb'
    option 'vlan' '2'
    option 'ports' '0 5t'

    ================
    Thats it. po issaugojimo konfiguracijos - rebooot routerio is rozetes isimt/idet.
    Pirmas paleidimas GALA TV gali uztrukti ant 4 porto.
    1,2,3 LAN portai.
    VLAN5 neparasome konfige - kadangi tai teo managementas.
    Test it and let us know!

    AtsakytiPanaikinti
  43. Aciu uz konfiga ;) kolkas viskas veikia puikiai :))) ziuresim kaip toliau bus :) tik su WiFi nepajungiu niekaip, konfigas gal ir geras bet ka ten butent su ugniasiene reikia padaryti?

    AtsakytiPanaikinti
  44. cia jau komentaruose skaitykit gerbiamas, tiksliai negaliu patarti su wifi- nes nennauduoju.

    AtsakytiPanaikinti
  45. Na jau ir su Wifi ok, bett... net cia atsakymo neradau :D ivedus i vln koki tai adresa kanalo ismeta lentele suvesk prisijungimo duomenis :/ kas cia? :}}}}

    AtsakytiPanaikinti
  46. :) tai pasidalink su kolegomis - gal kam prireiks kaip per wifi paleidai.
    O del slaptazodzio gal Teo praso sutarties numerio ir pwd ? Teo apkirpo haliava per wifi, jeigu ne paemiai tv.

    AtsakytiPanaikinti
    Atsakymai
    1. Prie ko čia Wifi ir GALA? Tiesiog išnaudojo udpxy limitą ir prašo login

      Panaikinti
  47. AUKSCIAU ESANCIU POSTU PASINAUDOJAU :)


    pridėti į /etc/config/firewall:

    config rule
    option src wan
    option proto igmp
    option target ACCEPT

    config rule
    option src wan
    option proto udp
    option dest_ip 224.0.0.0/4
    option target ACCEPT


    tada perkrauti firewall:
    fw restart

    tada pridėti į /etc/rc.local prieš pabaigą:
    ifconfig eth0.6 10.10.99.1 up
    udpxy -p 4022 -m 10.10.99.1 -B 4Kb -c 10

    exit 0


    ir įvykdyti:
    /etc/rc.local

    Viskas, veikia su vlc žiūrint:
    http://10.10.99.1:4022/udp/239.2.3.12:1234

    tai i ugniasiene tiesiog paciam gale irasiau visa sita reikala ir perkroviau fiziskai routeri nes kitaip neveike :/ tik va ir beda, ivedus ta adresa kur konfige yra tai rodo TV3 ir viskas ok, bet kitus suvedus tai iskart nori loginu :( paslaugas teo turiu ir tv, tad beda va tokia :)

    AtsakytiPanaikinti
    Atsakymai
    1. Jūs čia labai jau viską sunkiai konfigūruojat. Parašyk į skype: lizunas89 padėsiu viską puikiai sutvarkyi ;)

      Panaikinti
  48. pamirsau dar pradziai reikia iš pradžių į openwrt reikia suinstaliuoti udpxy:
    opkg update; opkg install udpxy

    AtsakytiPanaikinti
  49. viskas aišku, neveikia tiems kas neturi užsakę pačios galos tv,
    jei gala tv turi viskas veikia..
    žinau žmonių kuriems dar veikia ir be galos, bet jau po biški randasi kuriems nebeveikia

    AtsakytiPanaikinti
  50. Sveiki, vis bandau pagal pavyzdi susikonfiguruoti, bet niekaip nepavyksta :) gal galetumete pagelbeti? pradinis konfigas:

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

    config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

    config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0t 2 3 4 5'

    config switch_vlan
    option device 'eth0'
    option vlan '2'
    option ports '0t 1'

    AtsakytiPanaikinti
  51. Sveikas, gal gali ikelt nuotraukas po zingsnio:
    Isijungia SSH – todel jau reikia jungtis per tool`sus kuris palaiko SSH – Putty.exe"
    ar bent pasakyt kaip atsidaryt ta network faila is windows folderio per Putty.exe, nes niekur nerandu per kur tai galetu padaryt.. :/ Buciau labai dekingas, aciu :)

    AtsakytiPanaikinti
  52. Sveikas, turiu nauja 1043nd v2 isirasiau openwrt bet kai irasau config crashina modemas tai gal netinka jis ?

    AtsakytiPanaikinti
  53. Sveiki, gal kas padėtumėte sukonfiguruoti?

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

    config interface 'wan'
    option ifname 'eth0.2'
    option proto 'dhcp'

    config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0t 2 3 4 5'

    config switch_vlan
    option device 'eth0'
    option vlan '2'
    option ports '0t 1'

    Ačiū.

    AtsakytiPanaikinti
  54. Sveiki, bandziau padaryti ant savo TPlink WR841N, bet nepavyko. Aisku pas mane truputi skiriasi konfiguracija. Bandziau ja keisti bet nepavyko nugaleti :) Jeigu galite parasykite, patarkite kaip turetu buti, o stai pateiksiu pradine versija.

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config interface 'lan'
    option ifname 'eth1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'

    config interface 'wan'
    option ifname 'eth0'
    option proto 'dhcp'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 4'

    Aciu

    AtsakytiPanaikinti